System Restore saves the day, again

I know a lot of people who think System Restore is a waste of time and immediately turn it off when they install Windows.  Of course they change their tune when something bad happens and they’re looking at reinstall.

I admit I never really made use of the feature when it was introduced in Millennium; mainly because I never really used ME beyond the basic beta testing as I was dual booting between Windows 2000 at the time (and you can guess which I preferred).  However, I’ve used it plenty of times while using XP, especially during the service pack betas and dealing with poorly written software.  I was quite pleased that in Vista the feature has been even further expanded and I made use of it on more than occasion during the beta, the final and today with SP1.  However, SP1 isn’t (at least directly) the problem here.  The problem is good old AIM.

It all started earlier today when I noticed on my Neowin feed that AIM 6.5 had been released.  I’ve been using AIM since the abandoning of ICQ back in the late 90s, and although most of my communication is done via Messenger, there’s a few people whom I’m able to far more reliably communicate with on AIM.  Plus, I get to see what the "competition" is up to.

I’ve been using the 6.5 beta releases, so I didn’t really think much of updating to the final.  The installer (which is a custom made thing that doesn’t make a system restore point) took its time and almost appeared almost hung for awhile — the countdown went to 0 and then restarted at 10 seconds several times.  With that finished, AIM started, and I didn’t think anything of it.

Then Sam asked me a question a few minutes later which prompted me to open Network and Sharing Center.  Except it didn’t come up, instead I got an "Access is denied" in place of the Sharing Center.  Unfortunately I have seen this before and knew exactly what was happening — WMI wasn’t starting.  With that in mind, I checked System Properties and things weren’t coming up there either.

I rebooted, and sure enough none of my WMI-dependent gadgets were working.  Checked the Event Viewer, the Network List Service had failed as well as bunch of other services.  Now this had happened before on my old PC shortly after Vista was released and I ended up having to reinstall several times without being able to localize the problem. 

So, I launched System Restore and went back to yesterday.  After that completed, I checked everything and all seemed to work.  Over the past few days I’d installed a new beta of Winamp, a new version of IntelliPoint and plugged in the USB Xbox 360 wireless receiver.  All of that seemed fine.  Then I clicked the AIM icon and nothing happened.

So I install the latest AIM again.  The setup acted exactly the same as before and AIM finally came up per normal.  I checked the Network and Sharing Center.  Dead.  System Properties, dead.  AIM had killed it.

So I System Restored again back to yesterday, checked that WMI was working and then installed AIM — it killed it again.  So another restore later, I once again had a working PC.  However, there was still the matter of getting my old version of AIM back.  To do that, I simply went to Previous Versions on the AIM folder, copied one of the folders from a few days ago onto the Desktop, cleared out the AIM folder and moved the old one back.  The old version of AIM is now running fine and my Network and Sharing Center is still normal.

It will be interesting to see if anyone else reports this problem.  I may give it a go in a VM later to see if I reproduce it there. So, once again System Restore saved the day and the lesson taught once again: leave it on.

Posted on October 3, 2007, in Uncategorized. Bookmark the permalink. 3 Comments.

  1. wow!!  what a heck of a lot of effort for their crap AIM client.  :)  Glad everything is ok tho!  yay System Restore!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: